current position:Home>WxPython download has been reporting errors

WxPython download has been reporting errors

2022-05-15 04:34:59CSDN Q & A

  1. C:\Users\ Sun Zhenghui >pip install -U wxPython
    Collecting wxPython
    Using cached wxPython-4.1.1.tar.gz (66.0 MB)
    Preparing metadata (setup.py) ... done
    Requirement already satisfied: pillow in d:\lib\site-packages (from wxPython) (9.1.0)
    Requirement already satisfied: six in d:\lib\site-packages (from wxPython) (1.16.0)
    Requirement already satisfied: numpy in d:\lib\site-packages (from wxPython) (1.22.3)
    Building wheels for collected packages: wxPython
    Building wheel for wxPython (setup.py) ... error
    error: subprocess-exited-with-error

× python setup.py bdist_wheel did not run successfully.
│ exit code: 1
╰─> [51 lines of output]
D:\lib\site-packages\setuptools\dist.py:717: UserWarning: Usage of dash-separated 'license-file' will not be supported in future versions. Please use the underscore name 'license_file' instead
warnings.warn(
D:\lib\site-packages\setuptools\dist.py:294: DistDeprecationWarning: use_2to3 is ignored.
warnings.warn(f"{attr} is ignored.", DistDeprecationWarning)
running bdist_wheel
running build
C:\Users\ Sun Zhenghui \AppData\Local\Temp\pip-install-usvt1uxb\wxpython_7e6c7b87f7974aedb7807896e1ec7f31\build.py:41: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives
from distutils.dep_util import newer, newer_group
Will build using: "D:\python.exe"
3.10.4 (tags/v3.10.4:9d38120, Mar 23 2022, 23:13:41) [MSC v.1929 64 bit (AMD64)]
Python's architecture is 64bit
cfg.VERSION: 4.1.1

  Running command: build  Running command: build_wx  Command '"D:\python.exe" -c "import setuptools, distutils.msvc9compiler as msvc; mc = msvc.MSVCCompiler(); mc.initialize(); print(mc.cc)"' failed with exit code 1.  Traceback (most recent call last):    File "<string>", line 1, in <module>    File "D:\lib\distutils\msvc9compiler.py", line 371, in initialize      vc_env = query_vcvarsall(VERSION, plat_spec)   



Take the answer :

Current and current wxPython Version is 4.1.1, Only to Python 3.9, I won't support it Python 3.10


copyright notice
author[CSDN Q & A],Please bring the original link to reprint, thank you.
https://en.pythonmana.com/2022/131/202205041958460265.html

Random recommended